MULTIMEDIA SYSTEMS PRACTICALS SOLUTIONS .
1. create an image with line, rectangle, square and other basic
shapes.
Follow these quick steps to draw a line:
1. Select the Line tool. From the toolbar, click and hold the Shape tool ( ) group icon to bring up the various shape tool
choices. Select the Line tool.
2. Set the width of your line. Shape Mode: ...
3. Click and drag. Click on the canvas, drag, and release to create a line.

Draw a rectangle
The Rectangle tool allows you to draw rectangles and rounded rectangles on your canvas:
1.

Select the Rectangle tool
From the toolbar, click and hold the Shape tool (
choices. Select the Rectangle tool.

2.

) group icon to bring up the various shape tool

Adjust the shape properties of the Rectangle tool

Set the Rectangle properties

In the shape tool options bar, you can set:


Mode: Set a mode for your Rectangle tool — Shape, Path, and Pixels.



Fill: Choose a color to fill your rectangle shape.



Stroke: Choose the color, width, and type of your shape stroke.



Stroke width: Manually set width for your rectangle stroke.



Stroke type: Select the stroke type for drawing a rectangle.



Shape W&H: Manually set the width and height of your shape.



Path operations: Use path operations to set the way your drawn rectangles interact with each other.



Path alignment: Use path alignment to align and distribute your rectangles.



Path arrangement: Use path arrangement to set the stacking order of rectangles you create.



Additional shape and path options: Click the gear (
) icon to access additional rectangle shape and path
options to set attributes such as width and color of the on-screen display of your path, and constrain
options while drawing rectangles.



Radius of rounded corners: Manually set the radius for rounding the corners of your rectangle.

Draw a rectangle
Click on the canvas to bring up the Create Rectangle dialog. You can use this dialog to maually set the
dimensions, corner radii of your rectangle, and choose to align from centre. Click OK to enable changes.
Position your pointer and drag on the canvas to draw a rectangle. This automatically creates a new layer in
the Layers panel.

Note:
With the March 2021 release of Photoshop 22.3, the Rounded Rectangle tool has been removed. However, you can
easily use the improved Rectangle tool with the capability to draw rounded rectangles with a field to set corner radii.

Edit rectangle shape properties
You can easily edit your shape properties directly using on-canvas controls or accessing Shape
Properties under the Properties panel.

2. create a new image adding background colour and
foreground colour.
Set your Background and Foreground Colors
In your Toolbar, set your Background Color to white by double-clicking on the Background Color icon. In the Color
Picker (Background Color) dialog box, click on the upper left-hand corner of the large color box.

Next set your Foreground Color to a medium gray. Double click on the Foreground Color square in the Toolbar. In
the Color Picker (Foreground Color) dialog box, click midway down the left side of the large color box.
Other colors in the large color box (such as the blues and reds visible in the Color Picker panel image below) are irrelevant
since you're keeping the cursor all the way to the left side of the large color box.

Creating a Basic Shape
1. GIMP is not designed to be used for drawing.[4] However, you may create shapes by either painting them
using the technique described in Section 14.1, “Drawing a Straight Line” or by using the selection tools. Of
course, there are various other ways to paint a shape, but we'll stick to the easiest ones here. So, create
a new image and check that the foreground and background colors are different.

2. Cre atin g a re cta ng ular sele ctio n

The screenshot shows how a rectangular selection is created. Press and hold the left mouse button while
you move the mouse in the direction of the red arrow.

Basic shapes like rectangles or ellipses, can be created using the selection tools. This tutorial uses a
rectangular selection as an example. So, choose the rectangular selection tool and create a new selection:
press and hold the left mouse button while you move the mouse to another position in the image (illustrated
in figure Figure 7.37, “Creating a rectangular selection”). The selection is created when you release the
mouse button. For more information about key modifiers see selection tools.

3. Re cta ng ular s ele ctio n filled w ith fore gr ou nd col or

The screenshot shows a rectangular selection filled with the foreground color.

3 .Create a new image fill with various pattern(fill type).
1. Open an image. Use the Rectangle Marquee to select an area. Go to Edit > Define Pattern > name it > OK.
2. Next, open another image and select an area to fill > Edit > Fill > Custom Pattern.
3. Choose your new pattern, select a blending mode > OK.
4.
Apply the custom fill pattern
To apply the custom fill pattern, follow these steps:

1.
2.

Select the shape to which you want to apply the custom pattern.
On the Format menu, click Fill. Under Fill, click the custom pattern from the bottom of the Pattern list, and then
click OK.
Note Alternatively, right-click the shape, point to Format, and then click Fill.

4.Draw curve, circle, arc, oval using tools panel and the
properties panel.
Drawing Shapes with the Rectangle and Oval Tools
The Flash Toolbar includes several tools for quickly creating simple geometric vector shapes. They are easy to use; you just click and drag on
the Stage to create the shapes. The Rectangle tool creates rectangles with square or rounded sides. The Oval tool creates circular shapes such
as ovals and circles. These shapes can be comprised of Strokes, which are lines that surround and define the shape, Fills, which are a color or
texture inside the shape, or both. You can create two types of shapes: Drawing or Primitive. Drawing, or standard, shapes are self contained;
the stroke and fill of a shape are not separate elements, while Primitive shapes (New!) are separate elements.

Draw with the Oval Tool


Click the Oval or Oval Primitive tool in the Toolbar.
Timesaver

Press O to select an Oval tool.



Select a Stroke and Fill Color from the Colors area of the Toolbar.



Click and drag on the Stage, and then release the mouse.
Timesaver

Press and hold Shift while you drag to create a circle.

Click to view larger image



In the Properties Inspector, change the values you want.

Draw with the Rectangle Tool


Click the Rectangle or Rectangle Primitive tool in the Toolbar.
Timesaver

Press R to select a Rectangle tool.



Select a Stroke and Fill color from the Colors area of the Toolbar.



Click and drag on the Stage, and then release the mouse.
Timesaver

Press and hold Shift while you drag to create a square.

Click to view larger image



In the Properties Inspector, change the values you want.

Draw a Rounded Rectangle


Click the Rectangle or Rectangle Primitive tool in the Toolbar.

Click to view larger image



Enter a value for the corner radius in the Properties Inspector (New!).



To create an exact size rectangle shape, select the shape, enter the width and height values in the Properties Inspector ( New!).

Click to view larger image



Click and drag on the Stage, and then release the mouse.

5.Create an animation using the tools panel and the properties
panel to draw use the following Pen, Pencil, brush ,lasso tool.

Brush

Use the Brush Tool (B) to custom-define a brush by setting parameters of the brush such as shape and angle. You
can create natural artwork in your projects by customizing the brush tool to suit your drawing needs. You can
choose, edit, and create a custom brush in Animate through the Property Inspector, when the brush tool is selected
in the toolbox.
For more information on the Brush tool, see Brush tool in Animate.

Pencil

Use the Pencil tool to draw and edit freehand lines.
To learn how to use the Pencil tool, see Lines and shapes in Animate.

Pen

Use the Pen tool (P) to draw straight and curved lines to create objects.
For detailed information on using the Pen tool, see the article on Drawing with the Pen tool.

6.Create a shape using GIMP selections.
1.
2.
3.
4.
5.

Using the shape of the brush to create shapes
Select the Pencil Tool from the tools menu.
In the Tool options menu, select the Brush icon. ...
Select a brush type that resembles the shape you want, such as block, star, or ellipse.
Set Hardness to 100.
Change the size and aspect ratio to your preferences.

Creating a Basic Shape
1. GIMP is not designed to be used for drawing.[4] However, you may create shapes by either painting them
using the technique described in Section 14.1, “Drawing a Straight Line” or by using the selection tools. Of
course, there are various other ways to paint a shape, but we'll stick to the easiest ones here. So, create
a new image and check that the foreground and background colors are different.

2. Cre atin g a re cta ng ular sele ctio n
The screenshot shows how a rectangular selection is created. Press and hold the left mouse button while
you move the mouse in the direction of the red arrow.

Basic shapes like rectangles or ellipses, can be created using the selection tools. This tutorial uses a
rectangular selection as an example. So, choose the rectangular selection tool and create a new selection:
press and hold the left mouse button while you move the mouse to another position in the image (illustrated
in figure Figure 7.37, “Creating a rectangular selection”). The selection is created when you release the
mouse button. For more information about key modifiers see selection tools.

3. Re cta ng ular s ele ctio n filled w ith fore gr ou nd col or
The screenshot shows a rectangular selection filled with the foreground color.After creating the selection,
you can either create a filled or an outlined shape with the foreground color of your choice. If you go for the
first option, choose a foreground color and fill the selection with the bucket fill tool. If you choose the latter
option, create an outline by using theStroke selection menu item from the Edit menu. If you're satisfied with
the result, remove the selection.

7 . Insert background image and do the following using blender.

a. Make annotations on the active area.
Annotate Tool
The annotation tool is available in multiple editors. With it notes can be added to e.g. 3D objects or node
setups.The annotation tool can be activated in the Toolbar on the left side. It has a couple of sub-tools listed below.
Annotate
Draw free-hand strokes in the main window.
Annotate Line
Click and drag to create a line.
Annotate Polygon
Click multiple times to create multiple connected lines. The current polygon is finished when Esc or RMB is
pressed.
Annotate Eraser
Click and drag to remove lines drawn previously.The eraser has a Radius setting found in Tool Settings ‣ Eraser .

Settings

Common
There is a panel, Sidebar ‣ View ‣ Annotations , in it multiple annotation layers can be managed.
Color
Adjusts the color of existing and new strokes.
Thickness
Adjusts the thickness of existing and new strokes.
Onion Skin
Shows a preview of strokes made in frames close by the current frame. Onion skinning only works in the 3D
Viewport and Sequencer. See the Grease Pencil documentation for an explanation of Onion Skinning.

3D Editor
When creating new annotations in the 3D View, there is one tool setting.
Placement
The Placement option determines where the line is drawn in 3D space.
3D Cursor
Draw on an imaginary plane that goes through the 3D cursor.
View
Draw in screen space instead of in 3D space. That means, that the line will stay on the same position in the screen,
even when e.g. the camera rotates.
Surface
Project the line on the surface under the mouse.

2D Editors
In 2D editors, the Placement option does not exist. When the annotation tool is enabled, the settings for managing
multiple layers can be found in the Tool ‣ Active Tool panel in the right Sidebar.

Selecting
By default Blender uses the LMB to select items in the Blender window. Alternatively, the RMB can be used
instead by changing the Preferences. Blender has several selecting tools that can be used across the different
editors.

Selection Tools
Select Regular
Reference
Hotkey:

LMB

Clicking on an item selects it, using modifier keys you can perform other operations.

Select Box
Reference
Menu:

Select ‣ Box Select

Hotkey:

B

To activate the tool, press B or click and drag LMB . With Select Box you draw a rectangle while holding
down LMB . Any item that lies even partially within this rectangle becomes selected. If any item that was last active
appears in the selection it will become active.
For deselecting items, use MMB .

Box Select example.

Start.

Selecting.

Complete.

Select Circle
Reference
Menu:

Select ‣ Circle Select

Hotkey:

C

Select Circle C is used by moving with dotted circle through item with LMB . You can select any item by touching of
the circle area. It is possible to dynamically change the diameter of circle by scrolling Wheel or
with NumpadPlus and NumpadMinus as seen in pictures below. Deselection is under the same principle – MMB .

Circle Select example.

Start.

Selecting.

B.Scale( Resize selected items)
Selecting
By default Blender uses the LMB to select items in the Blender window. Alternatively, the RMB can be used
instead by changing the Preferences. Blender has several selecting tools that can be used across the different
editors.

Selection Tools
Select Regular
Reference
Hotkey:

LMB

Clicking on an item selects it, using modifier keys you can perform other operations.

Select Box
Reference
Menu:

Select ‣ Box Select

Hotkey:

B

To activate the tool, press B or click and drag LMB . With Select Box you draw a rectangle while holding
down LMB . Any item that lies even partially within this rectangle becomes selected. If any item that was last active
appears in the selection it will become active.
For deselecting items, use MMB .

Box Select example.

Start.

Selecting.

Complete.

Select Circle
Reference
Menu:

Select ‣ Circle Select

Hotkey:

C

Select Circle C is used by moving with dotted circle through item with LMB . You can select any item by touching of
the circle area. It is possible to dynamically change the diameter of circle by scrolling Wheel or
with NumpadPlus and NumpadMinus as seen in pictures below. Deselection is under the same principle – MMB .

Circle Select example.

Start.

Selecting.

8 . Create your own text and apply different font styles, size,
aligments and color.
In Microsoft Word, you can change the properties of any text, including font type, size, and color,
and make it bold, italic, or underlined (font style). The following illustration shows an example of
the formatting bar and a description of the tools it contains.

The font settings placement changed after Word 2003, with all the settings placed in
the Font section on the Ribbon's Home tab. An example of the font settings in Word 2016 is pictured
below.

Select a link below to learn how to change font color, size, style, or type in Microsoft Word.
Changing font color
To change the font color in a Microsoft Word document, follow the steps below.
1. Highlight the text you want to change.
2. Click the down arrow next to the color icon on the formatting bar or Ribbon. It is
usually displayed as the letter "A" with a red underline.After clicking the down
arrow, select a color for the text.
Changing font size
To change the font size in a Microsoft Word document, follow the steps below.
1. Highlight the text you want to change.
2. Click the down arrow next to the size box on the formatting bar or Ribbon to enlarge
or reduce the font size. The default font size is usually 11 or 12.
Align text in WordPad

To change the horizontal alignment of text in WordPad, highlight the text and click the left, center,
or right alignment icons in the Paragraph section of the menu bar.

3. After clicking the down arrow for the size, you see a list of predesignated sizes to
select. Some fonts do not scale appropriately to have limited size options.
4. You can also change the font size by clicking and highlighting the current default
size. In the picture above, the default is 11. Once highlighted, you can type in a
number. For example, if you want to use font size 100, you can type in that number
rather than choosing a preset number from the list.
Changing font style
To change the font style, including bold, italic, and underline, follow the steps below in a Microsoft
Word document.
1. Highlight the text you want to change.
2. Click the B, I, or U option on the formatting bar or Ribbon to change the text to
bold, italic, or underlined.After clicking the B, I, or U option, the text changes to the
selected font style.
Changing font type
To change the font type in a Microsoft Word document, follow the steps below.
1. Highlight the text you want to change.
2. Click the down arrow next to the font field on the formatting bar or Ribbon. (If you
want to change the font to bold, italic, or underlined, click the B, I, or U on the
format bar.)After clicking the down arrow for the font, select the desired font from
the list of installed fonts on your computer, like Arial, Calibri, and Times New
Roman.
Align text in WordPad
To change the horizontal alignment of text in WordPad, highlight the text and click the left, center,
or right alignment icons in the Paragraph section of the menu bar.

9 . Create text using text editor apply various formatting like Bold,
Italic, underline and strike through.
Add bold, italic, underline and strikethrough to text in Pages on Mac
1. Select the text you want to change.
To change all the text in a text box or table cell, select the text box or table cell.
2. In the Format

sidebar, click the Style button near the top.

If the text is in a text box, table or shape, first click the Text tab at the top of the sidebar, then click the Style button.

3. Click one or more format buttons in the Font section.
To remove a specific format, click that button again.
If the font you’re using has other styles available (such as light or condensed), click the pop-up menu above the
buttons to choose one of the styles.

10. Create text using text editor tool apply Justify like left
justify, right justifyand centre justify.
Align text left or right, center text, or justify text on a page
Alignment determines the appearance and orientation of the edges of the paragraph: left-aligned text, rightaligned text, centered text, or justified text, which is aligned evenly along the left and right margins. For example, in
a paragraph that is left-aligned (the most common alignment), the left edge of the paragraph is flush with the left
margin.
Vertical alignment determines the position of the text within a section of a document relative to the top and
bottom margins, and is often used to create a cover page.
Aling text lift to right
1.

Select the text that you want to align.

2.

On the Home tab, in the Paragraph group, click Align Left

or Align Right

.

Align text centre justify.

1.

Select the text that you want to center.

2.

On the Home tab, in the Paragraph group, click Center

.

3.

Select the text that you want to center.

4.

On the Home tab, in the Paragraph group, click Center

.

Tips:


In the Paragraph group, click the Dialog Box Launcher
your justified text.

, and select the Alignment drop-down menu to set



You can also use the keyboard shortcut, Ctrl + J to justify your text.

11. Create an animation in which text Hello gets
converted into GoodBye(using motion/shape tweeing).
Creating a motion tween animation
You can create a motion tween using one of the following three methods:


Create a graphic or instance that you want to tween, and then right-click a frame and select Create Motion Tween.



Select the graphic or instance that you want to tween, and select Insert > Motion Tween from the main menu.



Create a graphic or instance that you want to tween, and then right-click the instance on the Stage and
select Create Motion Tween.

Usage of ActionScript in animation is optional.

Creating a Motion tween Animation

Tweening other properties with the Property inspector
Use the Create Motion Tween command to animate properties of a symbol instance or text field. The properties
range from rotation, scale, transparency, or tint (symbols and TLF text only). For example, you can edit the alpha
(transparency) property of a symbol instance to make it fade onto the screen.
1.

Select a symbol instance or text field on the Stage.

If the selection contains other objects, or it contains multiple objects from the layer, Animate offers to
convert it to a movie clip symbol.
2.

Choose Insert > Motion Tween.
If the “Convert selection to symbol for tween” dialog box appears, click OK to convert the selection
into a movie clip symbol.
When you apply a tween to an object that exists only in a single keyframe, the playhead moves to the
last frame of the new tween. Otherwise the playhead does not move.

3.

Place the playhead in the frame of the tween span where you want to specify a property value.
You can place the playhead in any other frame of the tween span. The tween starts with the property
values in the first frame of the tween span, which is always a property keyframe.

4.

With the object selected on the Stage, set a value for a non-position property, such as alpha
(transparency), rotation, or skew. Set the value with the Property inspector or with one of the tools in
the Tools panel.
The current frame of the span becomes a property keyframe.

You can display different types of property keyframes in tween spans. Right-click (Windows) or Ctrlclick (Macintosh) a tween span and choose View Keyframes > property type from the context menu.



5.

Scrub the playhead in the Timeline to preview the tween on the Stage.

6.

To add more property keyframes, move the playhead to the desired frame in the span and set a value for
the property in the Property inspector.

How to Create a Motion Tween in Flash?
Last Updated : 07 Dec, 2021

Flash is an animation software that is used to create different types of animations. It is a vector -based
application which means that animations can be zoomed to any level without losing quality while quality
gets damaged in the case of pixel-based animations. It is used to animate frame by frame which is a
traditional method of animation and it is also used in animations involving graphic symbols means just
tweening the different parts of any character to give a motion effect.

Motion Tweening
Motion tween is one of the most used features for animations involving graphic symbols rather than hand
drawings. When animating with motion tweens one has to create the first frame only and then apply motion
tween which will give a motion path for the next frame which can be used to guide the graphic symbols and
make the animation look smoother. Motion tweening is different from classic and shapes tween as in these
tweens one needs to fill two keyframes while working with motion tween, only one keyframe is enough to
get the motion path after which a second keyframe is created when that path is directed to some position.
This motion path can be used to give direction to the object which is being moved. It works for symbols not
for shapes so convert any shape to a graphic symbol before applying motion tweeting. Only one motion
tween is applied per layer if applied more motion tweens in a single layer then the results may be
unexpected and animation will be undesirable.
How to create motion tweening?
Let’s understand motion tweening with the help of an example:
Step 1: Run the Flash application. After loading, the below window will appear.

Step 2: Click on ActionScript 3.0.

Step 3: Following screen will appear.

Step 4: Draw a circle on the first frame using circle tool from the toolbar on left side.

Step 5: Now take the mouse pointer on the first frame and right-click, a list will appear, click on Create
Motion Tween.

Step 6: A dialog box will appear asking for changing the shape to a symbol, click OK.

Step 7: Now the frames from 1 to 24 are being highlighted as flash is making animation on 24 frames per
second and after applying motion tween it reaches to 24th frame.

Step 8: Now select the box using selection tool or pressing v on the keyboard and drag it to any side. It will
show a motion path after placing it to any position.

Step 9: Click on the play button below the timeline to see the motion tweening.

One can also manipulate this path to make the animation look smoother. Different types of animations like
bouncing a ball or moving of objects like moving a train or a bus from one point to another can be easily
created by Motion Tween.
Video Player
00:00
00:57

Advantages:
 It provides better controls for tweening objects.
 Only a single object is needed for the entire tween.
 Motion tweening can also be applied to 3D objects.

12. Create an outline Around Text (“text tool option”
window).





Step 1: Create your text object with the Text tool.
Step 2: Hold Alt and click on your text layer’s icon in the Layers palette to select the text outlines.
Step 3: Open the Select menu and use the Grow tool to set the width of the outline.
Step 4: Create a new layer below your text layer, fill the expanded selection, and you’re done!




Step 1: Create Your Text
Using the Text tool, create the text that you want to outline. GIMP’s text tools can be a bit finicky in my
experience, so don’t feel bad if it takes you a few minutes and a bit of frustration to get things set up just
right. Just breathe deeply and keep trying 😉

Step 2: Create A Selection
Next, we need to select the text so that we can work around the edges of the letters. If you tried to do this by hand, it would
take forever – and you probably would have pulled all your hair out long before you got close to finishing! It’s much easier to
just let GIMP calculate it for you.
The GIMP Layers palette with my text layer highlighted. Your text has its own layer in the Layers palette at the bottom right
of the GIMP interface (unless you’ve re-arranged the interface layout). Holding down the Alt key (Option on a Mac), click on
the ‘A’ icon for your text layer. Your text should now be outlined in the image window, shown below.

Good thing I didn’t try to do that by hand!
You can also right-click on the layer in the Layers palette and choose ‘Alpha to Selection’, which uses the layer’s transparency
setting as a guide for creating the selection. Since text layers are transparent by default except for the actual letters themselves,
we have a ready-made selection.
Now on to the outlining process!
Step 3: Adjust Your Outline
Now that you’ve got your text outlined with a selection marquee, you can start modifying it to get just the right outline shape.
There are two main ways of dealing with this, depending on how precise you want your outlines to be.
The first method uses the Border tool that I mentioned in the quick and easy guide at the beginning of the post. Open
the Select menu from the menu bar and choose Border. The Border Selection dialog box appears to let you customize the
adjustments.
Border Selection works using your current selection edges as a center point, so a setting of 4 pixels (as shown above) would
cover 2 pixels outside the edges of your letters and 2 pixels inside. Since we’re outlining text, I recommend setting Border
style to Hard to boost the clarity.
The other method uses the Grow Selection tool, also found in the Select menu. This simply expands your text selection
outwards by the set amount of pixels.
Using the Border Selection method gives you a bit more flexibility, because there are times when you might want your
outline to overlap your letterforms, but Grow Selection is a bit simpler for quick usage. There are also other ways to modify
your selection’s edges to get different effects.

13. Create text using text editor tool apply various
orientation effects.
Horizontal and Vertical Orientation
1. Launch Adobe Illustrator, go to the "File" menu and click "New" to open a new document. Click on the "Type
Tool" button or press the keyboard shortcut key "T." Click once anywhere inside the document to place a text
box.
2. Go to the "Type" menu and highlight the "Type Orientation" item in the drop-down menu. Select "Horizontal" or
"Vertical." Horizontal is the default text orientation. Vertical enables you to type vertically.
3. Type the text in the text box and click on the "Type Tool" button to validate it.
Custom Character Orientation
1. Click on the "Type Tool" button or press the keyboard shortcut key "T." Click once anywhere in the document to
create a text box.
2. In the Character panel, click once inside the character-rotation area.
3. Type a degree value between "-180" and "180" to orientate the text. For example, a positive value of "30"
degrees rotates each character in the text 30 degrees to the right, while a negative value of "-30" degrees
rotates each character in the text 30 degrees to the left.
4. Type the text in the text box and click on the "Type Tool" button to validate. If you are not satisfied with the
rotation, select all text and change the "Character Rotation" value. Press "Enter" and the new value is applied to
each character in the text.
Change the Angle of a Single Line of Type

1. Click on the "Type Tool" button or press the keyboard shortcut key "T." Click once anywhere in the document to
create a text box.
2. Click on the "Selection" tool button and use the cursor to select the text box.
3. Go to the "Object" menu, select "Transform" and click "Rotate." Type a value in degrees in the angle text box
and click "OK." For example, to set the line of type on a 45-degree incline, type "45" (without quotes).

14. Create a new layer apply Fill with transparency effect.
a. flip horizontally

b. Flip vertically

Change the appearance of transparent artwork on screen
Use the Display Performance dialog box to set transparency preferences. These preferences determine the on-screen quality of
transparent objects in new documents and in documents saved with modified preferences. You can also set the preferences to
turn on or off the display of transparency in the document. Turning off transparency in the display preferences doesn’t turn off
transparency when printing or exporting the file.
Note:
Before you print a file containing transparency effects, make sure that you check the transparency preferences first. Printing automatically
flattens the artwork, and may affect the appearance of the transparency effects.

1.

Choose Edit > Preferences > Display Performance (Windows) or Adobe InDesign > Preferences > Display
Performance (Mac OS).

2.

Select an option (Fast, Typical, High Quality) in the Adjust View Settings section to determine the on-screen
resolution of any effect in the document. The settings you change apply only to the option you select here:
Fast turns off transparency and sets the resolution to 24 dpi.



Typical displays low-resolution effects and sets the resolution to 72 dpi.



High Quality improves the display of effects, especially in PDF and EPS files, and sets the resolution to 144 dpi.
Drag the Transparency slider. The default setting is Medium Quality, which displays drop shadows and feathering.
Click OK.
When inks overlap with blend modes, choose View >Overprint Preview. This option ensures that you can see on screen
how any inks interact with transparency.

15. Create your own text and apply Arbitary rotation.
GIMP's free image editor can help you create compelling graphics for your business website, presentations and
documents. Like other image editors, GIMP has an indispensable Select tool that allows you to isolate parts of
an image and work on them. You also have the ability to modify selections that you make. For instance, if you’d
like a building that you highlighted to lean slightly to the left, simply select the building and rotate it using GIMP’s
Rotate tool.

1. Launch GIMP and open one of your images. Move to the Toolbox window and click the “Rectangular Select”
tool.

2. Click a point on the image, hold down your left mouse button and drag your mouse to draw a small rectangle.
The area inside the rectangle becomes your selection.
3. Move back to the Toolbox window and click the “Rotate” tool to select it.
4. Return to the selection you created and click inside the selection. GIMP opens the Rotate dialog window.
5. Type a value in the “Angle” text box. The value you type determines how far GIMP rotates the selection. Type
“45,” for instance, and GIMP rotates the selection 45 degrees. You can also drag the slider below the Angle text

box to rotate the selection. As you move the slider, the selection rotates. If you can’t see that happening, drag
the Rotate window so that you can see your image on the canvas.
6. Click the Rotate window’s “Rotate” button to apply your changes.

16 .Create your college logo that appears to be floating above
a background.
Intention
This tutorial is intended to introduce you to a few simple commands, and some concepts in order to create
a logo that appears to be floating above a background, like this:
The concepts are ones that you’ll likely come across multiple times while working in graphics processing.
Layer masks are used to isolate a part of an image, thus allowing it to be placed over a random
background for instance. The addition of a drop-shadow effect to make an object appear to be floating
over the background is another example.

Getting Started
Create a new image of appropriate size for your logo:
File → New…

This will open the “Create a New Image” dialog, with options for you to specify:

You can make this new image any dimensions you want, but for this tutorial I am going to specify
a Width of 256 px, and a Height of 128 px. I haven’t specified any other options. When you’re ready, hit
“OK” to create the new image.
You’ll be presented with the new image on your canvas. Chances are it will be a pure white image at this
point (it may be a different color depending on how your GIMP is setup to handle new images - if it is,
don’t worry).

Fill the New Image with Black
The first thing we are going to do is fill our new image with black. The first step to doing so is to make
sure that the Foreground Color is appropriately set. Click on the foreground color in the Color area to
bring up the “Change Foreground Color” dialog (if your foreground color is already black you don’t have
to do this step, but it can’t hurt to learn):
Click the foreground color to change.

The “Change Foreground Color” dialog allows you to now set the foreground color. We want to set the
color to black RGB(0, 0, 0):

With the foreground color set, we can now use the Bucket Fill Tool to fill in our image:
Tools → Paint Tools → Bucket Fill
Activating the Bucket Fill tool.

Once the tool is activated, your cursor should appear as to the left. To fill the layer you need only
click on the image area at this point. Your image should now fill with black.

Adding Some Text
Now we want to add text to our image to create our logo with. To see what we’re doing, though, will
require us to change the foreground color to something other than black (black text on black background
doesn’t show up so well).
Now, you can follow the above procedures again to set the foreground color. If your background color is
already white, though, you can quickly swap foreground/background colors using the arrows:
Swap Foreground/Background quickly.

You can also use they keyboard shortcut “X” to swap the colors.
With the foreground color set to white, we can now use the Text Tool to add some text to our image:
Tools → Text
Activating the Text Tool.

We can now draw a box on our canvas (image) to hold the text. You can click on the canvas where you’d
like the top-left corner of your box to be, and drag the mouse down to the bottom right corner. You don’t
have to worry about being exact at this point, because you can adjust the boundaries of the box after
the fact.
This is what you should see on your canvas after clicking and dragging from the top-left to the bottomright to define your text box:
Defining the text box boundaries.

If you’d like to re-size the box for some reason, you can now click and drag in any of the green
areas shown below:
Resize handles to modify text box boundary.

Your text will go into the black box inside the green areas shown above.
Once the text boundary box is sized appropriately, we can just type some text. In my case, I’ll use
my name:
Text Tool Options (left), canvas view (right).

Chances are when you first start entering text, it will be very small on your canvas. So let’s have a look at
some options on the Text Tool Options palette (left, above).
If you want to make your text appear bigger, you can change the Size in the field shown. For instance,
here I’ve chosen to set my Size to 100px.
You may also not like the font that is chosen by default. In that case, we can change the Font to
something better by clicking the icon. This will open a drop-down to scroll through all the fonts
that GIMP knows about on your system. You can see in my example that I’ve changed the font to “Tw
Cen MT Bold”.
Creating a new layer from all visible layers.

Once we’ve gotten the text how we want it, we can now create a new layer from all the visible layers so
far (the text layer, and the black background layer). On your Layers tab, right click on the text layer we
just made, and choose “New from Visible”.
Alternatively, you can also create a new layer from visible using the menu:
Layer → New from Visible

At this point, our layer palette will have three layers on it, the background, the text (“PAT”), and our new
layer “Visible”:

Notice that there is a white border around the “Visible” layer. This indicates that this layer is currently
active, so that any operations we perform will apply to this layer.
Which is good, because we are about to blur this new layer a bit!
To apply a slight Gaussian blur to this layer, we simply invoke the command through the menu:
Filters → Blur → Gaussian Blur…

This will invoke the Gaussian Blur dialog, where we can specify how much blur we want to apply:

The defaults were pretty good, but I wanted just a tad more blur, so I increased the Blur Radius to 7.
When you’re done, just hit “OK”.

Adding Some Color
Now that we have our text done, it’s time to add a splash of color!
We are going to add a new layer to our image first:
Layer → New Layer…

Or by Right-Clicking on the “Visible” layer in the layer palette, and choosing “New Layer…” from the
context menu:
New Layer using the Right-Click context menu.

The “Create a New Layer” dialog will appear - it doesn’t matter what it gets filled with, so you can leave
it at whatever Layer Fill Type it’s set at (White by default I believe). Hit OK to create the new layer.
We are now going to fill this new layer with some color to add some interest. To do this we will use
the Plasma plugin:
Filters → Render → Noise → Plasma…

I just left the default values and hit OK, but feel free to fiddle with the values. Our layers now look
like this:

Here is what my canvas looks like right now (with the plasma layer on top and visible):

Bump Mapping
Now we’re going to use the text we created earlier to generate a fake 3D shape on this plasma layer. The
process is known as “bump mapping”. I won’t get into the technical details of how this works, as it is best
seen rather than explained. Open the Bump Map dialog through the menu:
Filters → Map → Bump Map…

The Bump Map dialog gives a good preview of what the plugin does:

To get it working correctly, this plugin requires that you properly point to the source for the bump
mapping. In our case the source is the text layer we created earlier (the layer was named “Visible”). So
we’ll click on the spinner for the Bump map, and choose our “Visible” layer from the list.
As before, feel free to play with the options. The only one that I changed was the Depth to increase the
illusion of depth (I finally set the value to 6 in my example). Once it looks good, we’ll hit the OK button
to apply it to the layer.

Apply a Layer Mask
Now we are going to use a Layer Mask to isolate our bump mapped text. First we need to add a Layer
Mask to the plasma layer:
Layer → Mask → Add Layer Mask…

Or Right-Click on the plasma layer and choose “Add Layer Mask…” from the context menu:

When the “Add a Mask to the Layer” dialog comes up, set the Initialize Layer Mask to: White
(full opacity).
Once you’ve added a mask to the plasma layer, your layers should now look like this:

Remember, you can tell which layer (or mask) is active by noticing which one has the white border
around it. The layers above show that the plasma layers mask is active (there is a white border around the
white mask, so it’s hard to notice, but no other layer/mask has a white border.
We are going to copy the “Visible” layer, and paste it into the layer mask for the plasma layer. So first,
Left-Click on the “Visible” layer in the layers palette to activate it:
Remember, the white border will indicate the layer is active.

With the layer active, we want to now copy it:
Edit → Copy

Then we want to make the plasma layer mask active by Left-Clicking on the mask:
Plasma layer mask now active again.

With the mask active again, we now want to paste the “Visible” layer back into the image:
Edit → Paste

This will now insert a Floating Selection (Pasted Layer) into your image:

To get this Floating Selection into the mask, we need to Anchor it:
Layer → Anchor Layer

This will Anchor the selection down onto the mask. Our image and layers should now look something
like this:

We may now want to add a different colored background to help us fine-tune the results we have so far.
Add a new layer to the image as we did when creating the plasma layer, and place it below the plasma
layer. (You can click and drag layers to change their order in the palette).
Pick an interesting background color and fill the new layer with this color. The layers should now look
like this:

It doesn’t look bad, but we can perhaps tighten up the results by adjusting the mask a bit to clarify the
edges of the text.

Adjusting the Levels
I want to clean up the edges of the text with what we have so far. Right now, the mask being used on the
plasma layer is a copy of the gaussian blurred text. To make it sharper, we are going to adjust the levels
on the mask for that layer.
To do this, we first make sure the layer mask is active by clicking on it. Then we can open the Adjust
Color Levels dialog through the menu:
Colors → Levels…

With the Adjust Color Levels dialog, we now want to sharpen up the edges of the mask a little bit:

What we want to do is adjust the Gamma and White point sliders. I started by dragging the White
point slider down to increase the prominence of the plasma layer, then pushed the Gamma up to
emphasize it more. (If you’re following along, you can also just copy my values from above).

The trick is to increase the definition of the edges of the text, without going too far and causing it to look
very jagged (aliased). Play with the settings to see how they affect your results. Here is what my plasma
layer looks like after applying the above levels to the mask:

Creating a Drop Shadow
Now we may want to get a little fancier and add an effect of a drop shadow behind the logo to make it
seem as if it’s floating above the background. We’ve already created what we need to generate this effect,
we just need to move a couple of things around to do so.
Make a copy of your “Visible” layer that had your original blurred text on it. Select the layer first to
activate it, then you can do:
Layer → Duplicate Layer

Or Right-Click on the “Visible” layer, and choose “Duplicate Layer”:

This will create a new layer called “Visible copy”. Move this layer above your background color layer to
just beneath your plasma layer as shown (you can Left-Click and drag the layer in the palette):
Click and drag the “Visible copy” layer to beneath the plasma layer

This layer will become our shadow, but we need to modify a couple of things first. We’ll first invert the
colors of the layer to make the text black using:
Colors → Invert

Then we need to change the layer so that all of the white areas will be transparent. This can be found in
the menu:
Layer → Transparency → Color to Alpha…

The layer should now have black text over a transparent background. We’ll now just want to shift this
layer a bit to simulate a height by offseting it down and to the right a bit. To do this we can use the Move
Tool:
Tools → Transfom Tools → Move
Activate the Move Tool.

If we hold down Shift and click on the canvas, we restrict the Move Tool to modifying only the active
layer (our shadow layer). Drag the layer to the right and down a bit to simulate the shadow. I ended up
with this:

Shadow layer shifted to the right and down a bit.

At this point we can make it a bit more fancy by adding a Gaussian Blur to the shadow to spread it out a
little more. We can also modify the layer Opacity, adjusting it to let the background show through a bit
as well.
Here is the final state of my image, where I applied a Gaussian Blur with a 10px radius, and adjusted the
shadow layer Opacity down to 80:

17. Create your own text and add object mirror effect and
transform rotate effect.
•

To rotate an object

•

To rotate an object around a ruler coordinate

•

To mirror an object

Rotating and mirroring objects
CorelDRAW lets you rotate and create mirror images of objects. You can rotate an object by
specifying horizontal and vertical coordinates. You can move the center of rotation to a specific ruler coordinate or to a
point that is relative to the current position of the object.

Rotating objects around a single point

Mirroring an object flips it from left to right or top to bottom. By default, the mirror anchor point is in the center of the
object.

Mirroring an object from top to bottom

To rotate an object
1.

Select an object.

2.

In the toolbox, click the Free transform tool

3.

Click the Free rotation button

4.

Type a value in the Angle of rotation box on the property bar.

.

on the property bar.

You can also view and set the relative center of an object by clicking the object to display the rotation handles
and dragging the relative center handle (circle with a dot in the middle) to a new position.
You can set the relative center of an object to its original position by enabling the Relative center check box
in the Transformation docker and clicking the center option in the area below the check box.
You can also rotate an object by using the Transform toolbar. To open the toolbar, click Window
Toolbars

Transform.

To rotate an object around a ruler coordinate
1.

Select an object.

2.

Click Window

3.

Disable the Relative center check box.

4.

Type a value in the Angle box.

5.

Type values in any of the following Center boxes:

Dockers

Transformations

Rotate.

•

H — lets you specify the point on the horizontal ruler around which the object rotates

•

V — lets you specify the point on the vertical ruler around which the object rotates
Press Enter.

6.

To mirror an object
1.

Select an object.

2.

Click Window

3.

In the Transformation docker, click one of the following buttons:

Dockers

•

Horizontal mirror

•

Vertical mirror

Transformations

Scale.

— lets you flip the object from left to right
— lets you flip the object from top to bottom

If you want to flip the object on a specific anchor point, enable the check box that corresponds to the anchor
point you want to set.
4.

Click Apply.

You can also mirror a selected object by holding down Ctrl and dragging a selection handle to the opposite
side of the object.
You can also mirror a selected object by clicking the Mirror horizontally or the Mirror vertically button on
the property bar.

18.Create your own text and apply viewport shading.
Setting up the Viewport¶
First, add a Viewport to the scene.Next, set the size of the Viewport to (1024, 512). The Viewport can actually be
any size so long as the width is double the height. The width needs to be double the height so that the image will
accurately map onto the sphere, as we will be using equirectangular projection, but more on that later.

Next, disable HDR and disable 3D. We don't need HDR because our planet's surface will not be especially bright, so
values between 0 and 1 will be fine. And we will be using a ColorRect to render the surface, so we don't need 3D
either.
Select the Viewport and add a ColorRect as a child.
Set the anchors "Right" and "Bottom" to 1, then make sure all the margins are set to 0. This will ensure that
the ColorRect takes up the entire Viewport.

Next, we add a Shader Material to the ColorRect (ColorRect > CanvasItem > Material > Material
> New ShaderMaterial).

Basic familiarity with shading is recommended for this tutorial. However, even if you are new to shaders, all the
code will be provided, so you should have no problem following along.
ColorRect > CanvasItem > Material > Material > click / Edit > ShaderMaterial > Shader > New Shader > click / Edit:

19. Insert an Image in GIMP and perform the following.
a. Adjust colour curves.
Your Pixels and You
First there’s something you need to consider if you haven’t before, and that’s what goes into representing
a colored pixel on your screen.
1.Open up an image in GIMP.
2. Now zoom in.
3.Nope - don’t be shy now, zoom in more!
4. Aaand there’s your pixel. So let’s investigate what goes into making your pixel.
Remember, each pixel is represented by a combination of 3 colors: Red, Green, and Blue.
In GIMP (currently at 8-bit), that means that each RGB color can have a value from 0 - 255, and
combining these three colors with varying levels in each channel will result in all the colors you can see
in your image.
If all three channels have a value of 255 - then the resulting color will be pure white. If all three channels
have a value of 0 - then the resulting color will be pure black.
If all three channels have the same value, then you will get a shade of gray (128,128,128 would be a
middle gray color for instance).
So now let’s see what goes into making up your pixel:
The RGB components that mix into your final blue pixel.
As you can see, there is more blue than anything else (it is a blue-ish pixel after all), followed by green,
then a dash of red. If we were to change the values of each channel, but kept ratio the same between Red,
Green, and Blue, then we would keep the same color and just lighten or darken the pixel by some amount.

B. Perform Invert, Linear Invert and value Invert.
Value Invert
Ex ampl e for t he “ Val ue i nve rt” f ilter

This filter inverts Value (luminosity) of the active layer or selection. Hue and Saturation will not be affected,although

the color will sometimes be slightly different because of round-off error. If you want to invert Hue and Saturation
also, use Colors → Invert.
Note that hue and saturation can be distorted quite a bit when applying twice this filter for colors with a high
luminosity (for instance, HSV 102°,100%, 98%, a bright green, gives HSV 96°, 100%, 2% after a first application of
the filter , and 96°, 100%, 98% after a second application). Thus, you should not expect to be able to apply this
filter twice in a row and get back the image you started with.

How To Invert Colors In GIMP | The Complete Guide
Inverting the colors of your image is a great way to add some vintage artistic flare to your designs. Color
inversion is typically a straightforward process, but GIMP provides various alternatives and controls that may
come in handy if you know how to use them. In this tutorial we’ll be going over how to invert colors in GIMP,
and we’ll also taking a look at how the linear invert and value invert options work as well.
In short, the way to invert colors in GIMP is to select the layer you’d like to apply the changes to and navigate to:
Colors > Invert
This will perform a basic RGB color inversion. However, you may notice that there are additional inversion options
as well, namely linear invert and value invert. Let’s have a closer look at what all of these features do.

Invert Colors In GIMP
To invert colors in GIMP, select the layer you’d like to apply the changes to and navigate to Colors
> Invert. This will perform a standard RGB inversion where each color is swapped with its opposite
color on the color wheel.

In the following video tutorial I go over the process and explain how it all works in detail:
Continue on for the written instructions.
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How To Invert Colors In GIMP
Let’s first go over how to invert colors in GIMP using a standard RGB inversion.
For this demonstration I will be using the following example image:
For this demonstration I will be applying a color inversion to the example image above.
To invert the colors, simply navigate to:
Colors > Invert
Here’s how it looks once applied:

How the image looks once its colors are inverted.

Color Inversion Explained
Now that you know how to invert the colors of your image, let’s briefly go over exactly what happens when inverting
the colors of an image.
The following is an RGB color wheel:
Source: Wikimedia Commons
Whenever you invert the colors of an image, you are essentially taking every color in that image and swapping it
out with the color that opposes it on the RGB color wheel.
So for example, red pixels in your image will turn cyan, green pixels will turn magenta, blue pixels will turn yellow,
and vice versa. This happens because these are all colors that oppose each other on the color wheel.
Inverting colors causes them to be swapped out with the colors that oppose them on the RGB color wheel.
And the same works for grayscale shades as well. Black pixels become white, white pixels become black, and
grays are swapped too. 80% gray will become 20% gray, and vice versa.

Considerations
Here are a few tips and pointers to keep in mind whenever you invert colors in GIMP:
1. The color inversion will only be applied to the layer you have selected. If nothing changes on your screen
once invert is applied, it’s probably because you have the wrong layer selected.
2. Color inversions can be applied locally via selections. So if you only want to invert the colors of a specific
area of your image, and not the entire image/layer, all you have to do is create a selection around the area using
one of the many selection tools in GIMP.
3. Because color inversions can be applied to selections, that also means that you won’t be able to invert the
colors of the entire image if you have a selection enabled. This could be another reason why you might not
be getting the desired result when using this feature.
On Windows and Linux platforms, selections are easy to spot as they’re depicted as dotted marquees. However, if
you’re a Mac user then these selections are (for whatever reason) invisible. So you’ll have to deselect all just to be
safe.
To ensure that you have no selections enabled, navigate to:
Select > None
If the “none” option is grayed out then that means you don’t currently have any selections enabled.

How Linear Invert Works
GIMP doesn’t just allow you to do a simple RGB color inversion. It also has another option for inverting colors,
known as Linear Invert.
It’s not entirely known what exactly Linear Invert does from a technical point of view. There isn’t much information
out there about this feature. In fact, it’s a blank page on GIMP’s own website that simply reads “TODO”.
That being said, here’s a visual representation of what the Linear Invert feature does to an image once applied,
compared with a regular RGB invert:
A comparison of how Linear Invert works against standard color inversion.
Although I don’t know this for sure, I surmise that the point of Linear Invert is to invert the colors of the image, but
while maintaining some semblance of brightness and/or luminosity from the original image.

Whenever you invert the colors of an image using a standard RGB inversion, it tends to invert the brightness of the
image as well. Bright landscapes suddenly become dark and dreary, and vice versa. This is due to the nature of
how color inversion works.
The benefit of using Linear Invert is that you can invert the colors of an image, but without also inverting the
brightness.
Again, the documentation on this isn’t clear though. So if I’ve misunderstood this then feel free to correct me in the
comments.
To perform a Linear Invert, all you have to do is select the layer you’d like to apply the effect to and navigate to:
Colors > Linear Invert
It is located just beneath the standard invert option.

How Value Invert Works
The final way in which you can invert colors in GIMP is by performing a Value Invert.
Value inversion is fundamentally different than standard RGB color inversions. When performing a value invert,
you’re not actually inverting any of the colors. Instead, you’re invert the value (v) channel of that color’s HSV
model.
Here’s a visual representation of what happens when you perform a value invert:
How the image looks with Value Invert applied.
As you can see, the colors of the image didn’t change as much as the intensity of the dark/light areas did. This is
because only the value property was inverted.
Value represents the V property of an HSV (hue, saturation, value) color model.
If you open the color picker in GIMP and click on the HSV tab in the top-right corner, you can see the HSV
properties of the chosen color:
When a Value Invert is applied, the Value property of a color is inverted.
The value property operates on a scale of 0 to 100. Performing a value invert will flip that property to its opposite.
So for example, a color with a value of 80 will become 20 once inverted. A color with a value of 10 will
become 90 once inverted, so on and so forth. All of the color’s other properties will remain unchanged.
I’m not quite sure when a feature like value invert could be useful, but people use GIMP for many different reasons,
and I’m sure this feature wouldn’t be there if it weren’t useful to someone somehow. Do you have an example
usage for inverting a color’s value? If so then let me know in the comments!

Conclusion
Thanks to how robust and comprehensive of an application it is, there’s various ways in which you can invert colors
in GIMP — and not just a standard RGB inversion. There are commercial design applications out there that don’t
even have these options. Hopefully this lesson has shed some light on the workings of color inversion in GIMP.
To date, I just saved your tutorial on how to utilize GIMP invert colors. I have not used GIMP yet.
I can say I’ve used invert color utility in Windows Paint as it aids me in embroidering an image, especially
portraits. For me the natural colors fools me into thinking too much is a variable for doing a simple outline portrait
in thread. Seeing the normal against the inverted images portrays outline features to stitch. It even helped me in
trying to stitch my wife’s broad-curl hair.
So as an artist of sorts, I can say I found that use for inverting color. I have not used it for any other type of
image. I shall be exploring that as well, thanks to you.

20. Insert an image and do the following using blender.
a. Rotate it in different directions.
Rotating objects
Relevant to Blender v2.31 To rotate objects, activate Rotate mode by pressing RKEY. As in Grab mode, you can change the
rotation by moving the mouse, confirm with LMB, or ENTER cancel with RMB or ESC.
Rotation in 3D space occurs around an axis, and there are various ways to define this axis. Blender defines an axis by direction
and a point that it passes through. For example, by default, the direction of the axis is orthogonal to your screen.
If you are viewing the scene from the front, side, or top, the rotation axis will be parallel to one of the global coordinate system
axes. If you are viewing the scene from an angle, the rotation axis is angled too, which can easily lead to a very odd rotation of
your object. In this case, you may want to keep the rotation axis parallel to the coordinate system axes. Toggle this behaviour
by pressing MMB during Rotate mode and watch the angle display in the window header.
Alternatively, once you are in rotate mode, you can press XKEY, YKEY or ZKEY to constrain rotation along that axis of
the global reference. By pressing XKEY-XKEY (XKEY twice) you constrain rotation around the x axis of the Object local
reference. The same is true for double YKEY and ZKEY. As for Grab, a third keypress removes constraints.
It is possible to have a numerical imput for rotation exactly as it was for translations.
Select the point for the rotation axis to pass through with the pertinent menu in the header of the 3D window, as discussed
below. (Figure 5.1, “The rotation point selection buttons”).
The rotation point selection buttons
Bounding Box Center - the axis passes through the center of the selection's bounding box. (If only one object is
selected, the point used is the center point of the object, which might not necessarily be in the geometric center.
In Figure 5.1, “The rotation point selection buttons” it is on the middle of the rightmost edge, marked by a purple dot.
For more on this point, see the section called “EditMode”.)




Median Point - the axis passes through the median point of the selection. This difference is only relevant in EditMode,
and the 'Median' point is the barycentrum of all vertices.
3D Cursor - the axis passes through the 3D cursor. The cursor can be placed anywhere you wish before rotating. You
can use this option to easily perform certain translations the at the same time that you rotate an object.
Individual Object Centers - each selected object receives its own rotation axis, all mutually parallel and passing
through the center point of each object, respectively. If you select only one object, you will get the same effect as with
the first button.

If you're just getting started with rotation, don't worry too much about the foregoing details. Just play around with Blender's
tools and you'll get a feeling for how to work with them.
Keeping CTRL pressed switches to snap mode. In snap mode rotations are constrained to 5� steps. Keeping SHIFT pressed
allows fine tuning here too. The rotation of selected objects can be reset to the default value by pressing ALT-R.

B.Make annotations on the active area.
Annotate Tool

The annotation tool is available in multiple editors. With it notes can be added to e.g. 3D objects or node
setups.The annotation tool can be activated in the Toolbar on the left side. It has a couple of sub-tools listed below.

Annotate
Draw free-hand strokes in the main window.
Annotate Line
Click and drag to create a line.
Annotate Polygon
Click multiple times to create multiple connected lines. The current polygon is finished when Esc or RMB is
pressed.
Annotate Eraser
Click and drag to remove lines drawn previously.
The eraser has a Radius setting found in Tool Settings ‣ Eraser .

Settings
Common
There is a panel, Sidebar ‣ View ‣ Annotations , in it multiple annotation layers can be managed.
Color
Adjusts the color of existing and new strokes.
Thickness
Adjuts the thickness of existing and new strokes.
Onion Skin
Shows a preview of strokes made in frames close by the current frame. Onion skinning only works in the 3D
Viewport and Sequencer. See the Grease Pencil documentation for an explanation of Onion Skinning.

3D Editor
When creating new annotations in the 3D View, there is one tool setting.
Placement
The Placement option determines where the line is drawn in 3D space.
3D Cursor
Draw on an imaginary plane that goes through the 3D cursor.
View
Draw in screen space instead of in 3D space. That means, that the line will stay on the same position in the screen,
even when e.g. the camera rotates.
Surface
Project the line on the surface under the mouse.

2D Editors
In 2D editors, the Placement option does not exist. When the annotation tool is enabled, the settings for managing
multiple layers can be found in the Tool ‣ Active Tool panel in the right Sidebar.

Selecting
By default Blender uses the LMB to select items in the Blender window. Alternatively, the RMB can be used
instead by changing the Preferences. Blender has several selecting tools that can be used across the different
editors.

Selection Tools
Select Regular
Reference
Hotkey:

LMB

Clicking on an item selects it, using modifier keys you can perform other operations.

Select Box
Reference
Menu:

Select ‣ Box Select

Hotkey:

B

To activate the tool, press B or click and drag LMB . With Select Box you draw a rectangle while holding
down LMB . Any item that lies even partially within this rectangle becomes selected. If any item that was last active
appears in the selection it will become active.
For deselecting items, use MMB .

Box Select example.

Start.

Selecting.

Complete.

Select Circle
Reference
Menu:

Select ‣ Circle Select

Hotkey:

C

Select Circle C is used by moving with dotted circle through item with LMB . You can select any item by touching of
the circle area. It is possible to dynamically change the diameter of circle by scrolling Wheel or
with NumpadPlus and NumpadMinus as seen in pictures below. Deselection is under the same principle – MMB .

Circle Select example.

Start.

Selecting.

C.Scale( Resize selected items)
Selecting
By default Blender uses the LMB to select items in the Blender window. Alternatively, the RMB can be used
instead by changing the Preferences. Blender has several selecting tools that can be used across the different
editors.

Selection Tools
Select Regular
Reference
Hotkey:

LMB

Clicking on an item selects it, using modifier keys you can perform other operations.

Select Box
Reference
Menu:

Select ‣ Box Select

Hotkey:

B

To activate the tool, press B or click and drag LMB . With Select Box you draw a rectangle while holding
down LMB . Any item that lies even partially within this rectangle becomes selected. If any item that was last active
appears in the selection it will become active.
For deselecting items, use MMB .

Box Select example.

Start.

Selecting.

Complete.

Select Circle
Reference
Menu:

Select ‣ Circle Select

Hotkey:

C

Select Circle C is used by moving with dotted circle through item with LMB . You can select any item by touching of
the circle area. It is possible to dynamically change the diameter of circle by scrolling Wheel or
with NumpadPlus and NumpadMinus as seen in pictures below. Deselection is under the same principle – MMB .

Circle Select example.

Start.

Selecting.

21. Apply snake hook, rotate, cloth effects by using sculpting
and display it indifferent view points.
Snake Hook
Mode
Sculpt Mode
Tool
Toolbar ‣ Snake Hook

Shortcut
K

Pulls vertices along with the movement of the brush to create long, snake-like forms.

Brush Settings
Magnify
The Snake Hook brush tends to loose volume along the stroke, with Magnify value greater than 0.5 it’s possible to sculpt
shapes without losing volume.

Rake
A factor to support moving the mesh with rotation following the cursor’s motion.

Deformation
Deformation type that is used by the brush.

Radius Falloff
Applies the brush falloff to the tip of the brush.

Elastic
Modifies the entire mesh using an Elastic deformation, see also the Elastic Deform tool.

Thumb
Mode

Sculpt Mode
Tool
Toolbar ‣ Thumb

Similar to the Nudge brush, this one flattens the mesh in the brush area, while moving it in the direction of the brush
stroke.

Pose
Mode
Sculpt Mode
Tool
Toolbar ‣ Pose

This brush is used to pose a model simulating armature-like deformations. Several different deformation modes can
be used to perform IK deformations or altering and moving the proportions of the mesh. The falloff of the
deformation across multiple segments is controlled by the brush falloff curve.

Brush Settings
Deformation Target
How the deformation of the brush will affect the object.

Geometry
Brush deformation displaces the vertices of the mesh.

Cloth Simulation
Brush deforms the mesh by deforming the constraints of a cloth simulation.

Deformation
Deformation type that is used by the brush.

Rotate/Twist
Rotates segments around a pivot point that is calculated automatically based on the radius of the brush and the topology of the
model. When pressing Ctrl , the brush applies a twist rotation to the posing segments instead of using the rotation or an IK
deformation.

Scale/Translate
Alters the proportions of the mesh, using the origin of the segment as a pivot. While holding Ctrl the brush moves the entire
segment.

Squash/Stretch
Works similar to Scale/Translate however, it applies different scale values along different axes to achieve the stretching effect.
The pivot point for this mode is calculated by using the local space aligned to the segment.

Rotation Origins
Method to set the rotation origins for the segments of the brush.

Topology
Sets the rotation origin automatically using the topology and shape of the mesh as a guide.

Face Sets

Creates a pose segment per Face Set, starting from the active face set.

Face Sets FK
Simulates a Forward Kinematics deformation using the Face Set under the cursor as control.

Pose Origin Offset
Offset of the pose origin in relation to the brush radius. This is useful to manipulate areas with a lot of complex shapes like
fingers.

Smooth Iterations
Controls the smoothness of the falloff of the deformation.

Pose IK Segments
Controls how many IK bones are going to be created for posing.

Lock Rotation when Scaling
When using Scale/Translate Deformation, do not rotate the segment; only scaling is applied.

Keep Anchor Point
Keeps the position of the last segment in the IK chain fixed.

Connected Only
Causes the brush to only affect topologically connected elements. Disabling this can have an impact on performance; when
disabled, keeping the Max Element Distance as low as possible will help counteract the performance impact.

Max Element Distance
Maximum distance to search for disconnected loose parts in the mesh.

Rotate
Mode
Sculpt Mode
Tool
Toolbar ‣ Rotate

Rotates vertices within the brush in the direction in which the cursor is moved. The initial drag direction is the zero
angle and by rotating around the center you can create a vortex effect.

22. Merge an image from a file to the current image in
GIMP(use “File open as layers).
Open file1. jpeg using Gimp.
1.
2.
3.
4.

Save file1. jpeg in the native Gimp format. Say we save it to file1. ...
Expand the canvas. Go to the menu Image, next Canvas size. ...
Next choose Windows , then Dockable Dialogs, then Layers. This shows the layers dialog. ...
Now choose File, Open as Layers and open file2. jpeg .

23. Draw box and apply different colors.

Change the colors in a text box or shape
In a text box or shape, you can quickly change the color of text, the inside (fill) color, or the color of the border.
Let's select the shape—the Drawing Tools appear in the ribbon, with the Format tab active.

Here's the same shape after we changed the border to orange, the fill to a light green, and the text to black. We
used the Shape Outline, Shape Fill, and Text Fill commands, available on the Format tab under Drawing Tools.
Although the changes we'll make below are shown in Microsoft PowerPoint, they work the same way in Excel, Word,
Outlook, and Project.

Change the text color
1.

Select the shape or text box border. When you do that, the Drawing Tools appear.
To change multiple shapes or text boxes, click the first shape or text box, and then press and hold Ctrl while you
click the other shapes or text boxes.

2.

On the Drawing Tools Format tab, click Text Fill and, under Theme Colors, pick the color you want.
Note: The Text Fill and Text Outline menus might not be active until you start typing in your shape.

To change the text to a color that isn't in the theme colors
a. Select the shape or text box.
b. On the Drawing Tools Format tab, click Text Fill > More Fill Colors.
c. In the Colors box, either click the color you want on the Standard tab, or mix your own color on the Custom tab.
Custom colors and colors on the Standard tab aren't updated if you later change the document theme.

Change the inside (fill) color
1.

Select the shape or text box to change. When you do that, the Drawing Tools appear.
To change multiple shapes or text boxes, click the first shape or text box, and then press and hold Ctrl while you
click the other shapes or text boxes.

2.

Click Shape Fill, and under Theme Colors, pick the color you want.

To change the fill color to a color that isn't in the theme colors
a. Select the shape or text box.
b. On the Drawing Tools Format tab, click Shape Fill > More Fill Colors.
c. In the Colors box, either click the color you want on the Standard tab, or mix your own color on the Custom tab.
Custom colors and colors on the Standard tab aren't updated if you later change the document theme.

Change the border color
1.

Select the shape or text box border. When you do that, the Drawing Tools appear.
If you want to change multiple shapes or text boxes, click the first shape or text box, and then press and hold Ctrl
while you click the other shapes or text boxes.

2.

On the Drawing Tools Format tab, click Shape Outline and, under Theme Colors, pick the color you want.

To change the border to a color that isn't in the theme colors
a. Select the shape or text box.
b. On the Drawing Tools Format tab, click Shape Outline, and then click More Outline Colors.
c. In the Colors box, either click the color that you want on the Standard tab, or mix your own color on
the Custom tab. Custom colors and colors on the Standard tab aren't updated if you later change the document
theme.
Tip: In PowerPoint, you can also change the border color by clicking Shape Outline (on the Home tab, in
the Drawing group

24.Apply different filter effects to the image
A.blur
1.

Select a layer that contains content you want to blur, like a background.

2.

Choose Filter > Convert for Smart Filters. Click OK. This converts the selected layer into a
layer that will support re-editable filters.
With the same layer selected, choose Filter > Blur > Gaussian Blur.
In the Gaussian Blur dialog box, adjust the Radius control until you’re happy with the amount of blur in the live preview. Click
OK to apply the Gaussian Blur filter.

3.
4.
5.

6.

Note the Smart Filter that’s attached to your image layer in the Layers panel. This allows you to flexibly edit the filter settings.
To do that, double-click the Gaussian Blur Smart Filter in the Layers panel, make a change in the Gaussian Blur dialog box
that reopens, and click OK.
Save the image in Photoshop (PSD) format to retain the Smart Filter layer.

B.distorts.
 In the Edit workspace, select an image, layer, or a specific area.
 Select Filter> Distort > Displace.
 To define the magnitude of the displacement, enter a value between -999 and 999 in the Horizontal and Vertical

Scale text boxes.
When the horizontal and vertical scales are 100%, the greatest displacement is 128 pixels (because middle gray
produces no displacement).
 If the displacement map is not the same size as the selection, select how you want the map to fit the image:

Stretch To Fit
Resizes the map.
Tile
Fills the selection by repeating the map in a pattern.
 Select how to fill voids that are created by the filter in the image, and click OK.

Wrap Around
Fills voids with content from the opposite edge of the image.
Repeat Edge Pixels
Extends the colors of pixels along the image’s edge in the direction you specify.
 Select and open the displacement map. Photoshop Elements applies the map to the image.

C.Artistic with cartoon and photocopy.
Apply Artistic Effects
1. Select the picture.
2. Select Picture Tools > Format and select Artistic Effects.
3. Hover over the options to preview them and select the one you want.
Note: You can apply only one artistic effect at a time to a picture, so applying a different artistic effect will remove
the previously applied artistic effect.
Change the color
1. Select the picture.
2. Select Picture Tools > Format and select Color.
3. Hover over the options to preview them and select the one you want.

Apply Picture Effects
1. Select the picture.
2. Select Picture Tools > Format and select Picture Effects.
3. Select the one you want: Shadow, Reflection, Glow, Soft Edges, Bevel, or 3-D Rotation.
For more info, see Remove a picture background.

Add a border
1. Select the picture.
2. Select Picture Tools > Format and select a border.

Compress the picture
1. Select the picture.
2. Select Picture Tools > Format and select Compress Pictures.
3. Select the options you want and select OK.
For more info, see Reduce the file size of a picture.

30. Take two files in one folder with different MB and show
ZIP and UNZIP compression of files with steps.
Zipped (compressed) files take up less storage space and can be transferred to other computers more quickly than
uncompressed files. In Windows, you work with zipped files and folders in the same way that you work with
uncompressed files and folders. Combine several files into a single zipped folder to more easily share a group of
files.

To A Zip (compress) a file or folder.
1.

Locate the file or folder that you want to zip.

2.

Press and hold (or right-click) the file or folder, select (or point to) Send to, and then select Compressed (zipped)
folder.
A new zipped folder with the same name is created in the same location. To rename it, press and hold (or rightclick) the folder, select Rename, and then type the new name.

To UNZIP(extract) a file or folders from a zipped folder.
1.

Locate the zipped folder that you want to unzip (extract) files or folders from.

2.

Do one of the following:



To unzip a single file or folder, open the zipped folder, then drag the file or folder from the zipped folder to a new
location.



To unzip all the contents of the zipped folder, press and hold (or right-click) the folder, select Extract All, and then
follow the instructions.

